Monday, 8 September 2014

Quick Tip : P4Python Tickets and Motionbuilder 2013

Motionbuilder 2013 uses Python 2.6 and unfortunately P4Python 2.6 does not support tickets (or not in an obvious way that I could find). Trying to access tickets through the module will result in the following error.
However simply adding the run_tickets function from P4Python 2.7 into P4Python 2.6, will give you access to tickets through 2.6, and thus Motionbuilder.

Simply add the following function into your P4Python 2.6 module, within class P4().